OpenIT should target PHP 5.1?

  2005-10-12


According to the current poll on the OpenIT Community Site, the majority of people who have voted think OpenIT should target PHP 5.0 or greater.

While I would love to use all the nifty new object oriented features of PHP 5, the simple fact remains that the servers I use (Debian and Slackware) come with PHP 4.3 or 4.4. I’m guessing that a number of the voters in the Poll are Windows users who just upgrade to whatever PHP installer is at the top of the list.

There have been lots of posts on Planet-PHP about the slow adoption of PHP 5. I think the bottom line is that it just takes time. It’s going to be years before Microsoft can convince people to migrate their numerous Visual Basic 6 applications to .Net. In the same way its going to be years before people migrate from 4 to 5 (or perhaps straight to 6).